unicode problem with Microsoft Query

classic Classic list List threaded Threaded
3 messages Options
Reply | Threaded
Open this post in threaded view
|

unicode problem with Microsoft Query

ching lu
The testing environment is Win7 SP1 64 bit, Office 2010 64 bit,
Firebird 2.5.4 x64 embedded server, Firebird_ODBC_2.0.3.154_x64

I need to work with unicode table names and unicode column names.

The embedded database (charset=UTF8) is created with flamerobin x64,
the table names and column names worked ok

When i test with Excel (odbc client charset and server:are both UTF8)

1. The names are garbage characters when trying to with "Microsoft query"
2. The query works ok except for blob text column, it is garbage characters

Please help me

------------------------------------------------------------------------------
_______________________________________________
Firebird-odbc-devel mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/firebird-odbc-devel
Reply | Threaded
Open this post in threaded view
|

Re: unicode problem with Microsoft Query

ching lu
please find the screenshots:
https://drive.google.com/folderview?id=0B8V-YFTM0I7Ffm5CVkE3SElZMGQ1R2F1MkFFRU1VckJOYVJqaEJHWm1ibXFzeUhoczRvMkU&usp=sharing

On Tue, Jun 9, 2015 at 8:21 PM, ching lu <[hidden email]> wrote:

> The testing environment is Win7 SP1 64 bit, Office 2010 64 bit,
> Firebird 2.5.4 x64 embedded server, Firebird_ODBC_2.0.3.154_x64
>
> I need to work with unicode table names and unicode column names.
>
> The embedded database (charset=UTF8) is created with flamerobin x64,
> the table names and column names worked ok
>
> When i test with Excel (odbc client charset and server:are both UTF8)
>
> 1. The names are garbage characters when trying to with "Microsoft query"
> 2. The query works ok except for blob text column, it is garbage characters
>
> Please help me

------------------------------------------------------------------------------
_______________________________________________
Firebird-odbc-devel mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/firebird-odbc-devel
Reply | Threaded
Open this post in threaded view
|

Re: unicode problem with Microsoft Query

ching lu
Can someone helps? Thx.

On Wed, Jun 10, 2015 at 9:30 AM, ching lu <[hidden email]> wrote:

> please find the screenshots:
> https://drive.google.com/folderview?id=0B8V-YFTM0I7Ffm5CVkE3SElZMGQ1R2F1MkFFRU1VckJOYVJqaEJHWm1ibXFzeUhoczRvMkU&usp=sharing
>
> On Tue, Jun 9, 2015 at 8:21 PM, ching lu <[hidden email]> wrote:
>> The testing environment is Win7 SP1 64 bit, Office 2010 64 bit,
>> Firebird 2.5.4 x64 embedded server, Firebird_ODBC_2.0.3.154_x64
>>
>> I need to work with unicode table names and unicode column names.
>>
>> The embedded database (charset=UTF8) is created with flamerobin x64,
>> the table names and column names worked ok
>>
>> When i test with Excel (odbc client charset and server:are both UTF8)
>>
>> 1. The names are garbage characters when trying to with "Microsoft query"
>> 2. The query works ok except for blob text column, it is garbage characters
>>
>> Please help me

------------------------------------------------------------------------------
_______________________________________________
Firebird-odbc-devel mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/firebird-odbc-devel