icudt52.dll FB3

classic Classic list List threaded Threaded
3 messages Options
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

icudt52.dll FB3

D. Kruise

Hi i upgraded from embedded FB 2.5 to 3 (Firebird-3.0.2.32703-0_Win32.zip)


On Windows 10 32 bit no problem  but on Windows 10 64 bit icw Flamerobin i get the error couldn't find acceptable icu library


the  icudt52.dll (3kb) seems to be the problem because the original icudt52.dll from IBM 

which is 22.4 MB !! solved the problem. 


Is there a better/newer small compiled  icudt52.dll?


I installed in the exe directory 


FBclient.dll
firebird.msg
ib_util.dll
icudt52.dll
icuin52.dll
icuuc52.dll
And into subdir intl 

fbintl.conf
fbintl.dll
And into subdir plugins
engine12.dll


PS In combination with  IBExpert the 3 kb icudt52.dll does work on 64 bit?!


------------------------------------------------------------------------------
Check out the vibrant tech community on one of the world's most
engaging tech sites, Slashdot.org! http://sdm.link/slashdot
Firebird-Devel mailing list, web interface at https://lists.sourceforge.net/lists/listinfo/firebird-devel
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: icudt52.dll FB3

firebird-devel mailing list
10.07.2017 11:11, D. Kruise пишет:

...

> I installed in the exe directory
>
>
> FBclient.dll
> firebird.msg
> ib_util.dll
> icudt52.dll
> icuin52.dll
> icuuc52.dll

   Seems you missed icudt52l.dat. Also, make sure, you used 64-bit DLL's

> And into subdir intl
>
> fbintl.conf
> fbintl.dll
> And into subdir plugins
> engine12.dll
>
>
> PS In combination with  IBExpert the 3 kb icudt52.dll does work on 64 bit?!

   IBE is 32-bit application and it will be strange if it supply something 64-bit

Regards,
Vlad

------------------------------------------------------------------------------
Check out the vibrant tech community on one of the world's most
engaging tech sites, Slashdot.org! http://sdm.link/slashdot
Firebird-Devel mailing list, web interface at https://lists.sourceforge.net/lists/listinfo/firebird-devel
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: icudt52.dll FB3

D. Kruise

Thanks Vlad,


Adding icudt52l.dat solved the problem. Flamerobin 32 bit works now  on 32 bit and 64 bit windows OS.

I think adding icudt52l.dat for embedded use i (only for 64 bit WINDOWS 10 OS) is not well documented but 





Von: Vlad Khorsun via Firebird-devel <[hidden email]>
Gesendet: Montag, 10. Juli 2017 08:22
An: [hidden email]
Cc: Vlad Khorsun
Betreff: Re: [Firebird-devel] icudt52.dll FB3
 
10.07.2017 11:11, D. Kruise пишет:

...

> I installed in the exe directory
>
>
> FBclient.dll
> firebird.msg
> ib_util.dll
> icudt52.dll
> icuin52.dll
> icuuc52.dll

   Seems you missed icudt52l.dat. Also, make sure, you used 64-bit DLL's

> And into subdir intl
>
> fbintl.conf
> fbintl.dll
> And into subdir plugins
> engine12.dll
>
>
> PS In combination with  IBExpert the 3 kb icudt52.dll does work on 64 bit?!

   IBE is 32-bit application and it will be strange if it supply something 64-bit

Regards,
Vlad

------------------------------------------------------------------------------
Check out the vibrant tech community on one of the world's most
engaging tech sites, Slashdot.org! http://sdm.link/slashdot
Firebird-Devel mailing list, web interface at https://lists.sourceforge.net/lists/listinfo/firebird-devel

------------------------------------------------------------------------------
Check out the vibrant tech community on one of the world's most
engaging tech sites, Slashdot.org! http://sdm.link/slashdot
Firebird-Devel mailing list, web interface at https://lists.sourceforge.net/lists/listinfo/firebird-devel
Loading...