heads up: ICU 59.1 requires C++11

classic Classic list List threaded Threaded
1 message Options
Reply | Threaded
Open this post in threaded view

heads up: ICU 59.1 requires C++11

Michal Kubecek

last week I noticed my Firebird 2.5 packages started to fail building
for openSUSE Factory. A bit surprisingly this is not caused by the
switch to gcc7 but by an upgrade of ICU to 59.1.

According to their release notes, ICU 59.1 requires C++11 to build. An
immediate symptom is an error about unknown type uchar16_t. This would
be probably easy to  work around but there may be more subtle issues.
It's only a problem for Firebird 2.5 as 3.0 and newer use C++11 mode by
default anyway. For 2.5, though, most gcc6 compatibility issues were
worked around by enforcing C++98 mode (-std=gnu++98).

It's probably nothing really serious as distributions which are new
enough to provide ICU 59.1 most likely already have Firebird 3.0 which
is fine; I just wanted to give a heads up to save others time if they
run into this issue.

                                                        Michal Kubecek

Check out the vibrant tech community on one of the world's most
engaging tech sites, Slashdot.org! http://sdm.link/slashdot
Firebird-Devel mailing list, web interface at https://lists.sourceforge.net/lists/listinfo/firebird-devel