Quantcast

Build FB 3 on openSUSE 42.2 ICU problem

classic Classic list List threaded Threaded
4 messages Options
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Build FB 3 on openSUSE 42.2 ICU problem

Martin Schreiber
Hi,
I try to compile git B3_0_Release branch on openSUSE Leap 42.2. It fails
with
"
/home/mse/packs/standard/git/firebird/source_3_0/gen/Release/firebird/bin/isql
-q -i /home/mse/packs/standard/git/firebird/source_3_0/src/dbs/metadata.sql
can't format message 17:0 -- message file
/home/mse/packs/standard/git/firebird/source_3_0/gen/Release/firebird/firebird.msg
not found
Could not find acceptable ICU library
can't format message 17:120 -- message file
/home/mse/packs/standard/git/firebird/source_3_0/gen/Release/firebird/firebird.msg
not found
Makefile:331: recipe for target 'metadata.fdb' failed
make[3]: *** [metadata.fdb] Error 1
make[3]: Leaving directory
'/home/mse/packs/standard/git/firebird/source_3_0/gen'
Makefile:172: recipe for target 'master_process' failed
make[2]: *** [master_process] Error 2
make[2]: Leaving directory
'/home/mse/packs/standard/git/firebird/source_3_0/gen'
Makefile:66: recipe for target 'firebird' failed
make[1]: *** [firebird] Error 2
make[1]: Leaving directory
'/home/mse/packs/standard/git/firebird/source_3_0/gen'
Makefile:6: recipe for target 'firebird' failed
make: *** [firebird] Error 2
"
Package libicu52_1 is installed.
Thanks, Martin

------------------------------------------------------------------------------
Announcing the Oxford Dictionaries API! The API offers world-renowned
dictionary content that is easy and intuitive to access. Sign up for an
account today to start using our lexical data to power your apps and
projects. Get started today and enter our developer competition.
http://sdm.link/oxford
Firebird-Devel mailing list, web interface at https://lists.sourceforge.net/lists/listinfo/firebird-devel
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Build FB 3 on openSUSE 42.2 ICU problem

Michal Kubecek
On Tue, Mar 07, 2017 at 11:03:33AM +0100, Martin Schreiber wrote:
> I try to compile git B3_0_Release branch on openSUSE Leap 42.2. It fails
> with
> "
> /home/mse/packs/standard/git/firebird/source_3_0/gen/Release/firebird/bin/isql
> -q -i /home/mse/packs/standard/git/firebird/source_3_0/src/dbs/metadata.sql
> can't format message 17:0 -- message file
> /home/mse/packs/standard/git/firebird/source_3_0/gen/Release/firebird/firebird.msg
> not found
> Could not find acceptable ICU library

You would need the patch

  unicode-handle-the-ICU-version-hack-from-SuSE.patch

from

  https://build.opensuse.org/package/show/home:mkubecek:firebird30/firebird

It's ugly but I didn't get to replacing it with something nicer yet.

FYI: unless you have other reasons to do your build, there are ready to
use FB 3.0 packages in OBS projects server:database (copy of what is in
Tumbleweed) and home:mkubecek:firebird30 (recent git snapshot):

  http://download.opensuse.org/repositories/server:/database/openSUSE_Leap_42.2/
  http://download.opensuse.org/repositories/home:/mkubecek:/firebird30/openSUSE_Leap_42.2/

Michal Kubecek


------------------------------------------------------------------------------
Announcing the Oxford Dictionaries API! The API offers world-renowned
dictionary content that is easy and intuitive to access. Sign up for an
account today to start using our lexical data to power your apps and
projects. Get started today and enter our developer competition.
http://sdm.link/oxford
Firebird-Devel mailing list, web interface at https://lists.sourceforge.net/lists/listinfo/firebird-devel
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Build FB 3 on openSUSE 42.2 ICU problem

Martin Schreiber
On 03/07/2017 11:35 AM, Michal Kubecek wrote:
>
> FYI: unless you have other reasons to do your build, there are ready to
> use FB 3.0 packages in OBS projects server:database (copy of what is in
> Tumbleweed) and home:mkubecek:firebird30 (recent git snapshot):
>
>   http://download.opensuse.org/repositories/server:/database/openSUSE_Leap_42.2/
>   http://download.opensuse.org/repositories/home:/mkubecek:/firebird30/openSUSE_Leap_42.2/
>
Thanks, I need debuginfo and debugsource for libfbclient.so.3.0.1 which
I could not find in the packages. What is the correct package for
libfbclient debuginfo?

Martin

------------------------------------------------------------------------------
Announcing the Oxford Dictionaries API! The API offers world-renowned
dictionary content that is easy and intuitive to access. Sign up for an
account today to start using our lexical data to power your apps and
projects. Get started today and enter our developer competition.
http://sdm.link/oxford
Firebird-Devel mailing list, web interface at https://lists.sourceforge.net/lists/listinfo/firebird-devel
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Build FB 3 on openSUSE 42.2 ICU problem

Michal Kubecek
On Tue, Mar 07, 2017 at 01:54:38PM +0100, Martin Schreiber wrote:

> On 03/07/2017 11:35 AM, Michal Kubecek wrote:
> >
> > FYI: unless you have other reasons to do your build, there are ready to
> > use FB 3.0 packages in OBS projects server:database (copy of what is in
> > Tumbleweed) and home:mkubecek:firebird30 (recent git snapshot):
> >
> >   http://download.opensuse.org/repositories/server:/database/openSUSE_Leap_42.2/
> >   http://download.opensuse.org/repositories/home:/mkubecek:/firebird30/openSUSE_Leap_42.2/
> >
> Thanks, I need debuginfo and debugsource for libfbclient.so.3.0.1 which
> I could not find in the packages. What is the correct package for
> libfbclient debuginfo?

It should be libfbclient2-debuginfo which seems to be available in both
repositories. As for -debugsource, there is only firebird-debugsource as
debugsource packages are named after the source packages, not after
binary ones (like debuginfo). But it should provide sources for
everything built from firebird source RPM, including libfbclient2.

Michal Kubecek

------------------------------------------------------------------------------
Announcing the Oxford Dictionaries API! The API offers world-renowned
dictionary content that is easy and intuitive to access. Sign up for an
account today to start using our lexical data to power your apps and
projects. Get started today and enter our developer competition.
http://sdm.link/oxford
Firebird-Devel mailing list, web interface at https://lists.sourceforge.net/lists/listinfo/firebird-devel
Loading...